For the past 3 days I have trouble logging in reddthat using jerboa. I am able to log in to other accounts, including LW. Also, I am able to log in reddthat with the web app and Eternity. When I log in, I get a message Illegal input field, public_key is required (the full message is not visible).

I am using a password manager so I am sure I am using the correct credentials. I have reinstalled jerboa and deleted all data.

Anything I can try? Anyone else facing the same issue?

Edit: I have tried every version from 0.60 to 0.65, some of them I have used successfully in the past.

  • TiffMA
    link
    fedilink
    English
    arrow-up
    5
    ·
    edit-2
    2 months ago

    Bah! I forgot to let everyone know.

    Since we updated to the beta version of Lemmy 3 days ago, it seems it’s broken.

    I’ve already left Bug reports on Jerboa and Lemmy for the immediate issues. If we hadn’t found this out every Jerboa user would be in the same position.

    Unfortunately the issue came about because I used the latest Lemmy build to get the metadata patch and test it out. Unfortunately there were database migrations I missed so we are just going to roll with it.

    1. Nutomic is adding back public_key in a patch, once that is back in I’ll rebuild our container and jerboa will be back working
    2. Eternity is a good alternative for an android app (which is what I mainly use).

    I’m thinking it will be sorted by tomorrow? Hopefully. Otherwise I’ll make the code change myself and rebuild.

    Sorry for the issue & headache. I only saw the issue in the last 24h-ish as I only have jerboa for the occasional testing.

    Tiff