• Eager Eagle@lemmy.world
    link
    fedilink
    English
    arrow-up
    26
    ·
    edit-2
    10 months ago

    Unless they’re indices, do yourself a favor and use meaningful names instead.

    I avoid index iterations the most I can tbh. And for nested loops,i and k is more readable.

    • fidodo@lemm.ee
      link
      fedilink
      arrow-up
      12
      ·
      10 months ago

      Even for indexes I do index or something more specific for what it’s indexing. Any simple iteration I just do map or each so the only time I ever need to actually index things is for more complex scenarios in which case it’s worth it to have better names. Also with modem IDEs, auto complete is really good so you don’t need to write a full variable name more than once.

    • Alien Nathan Edward@lemm.ee
      link
      fedilink
      arrow-up
      4
      ·
      10 months ago

      When I was a baby coder back in the 90s we were taught that these names were meant to save space in the symbol table because at one time space was so limited that naming your variable n rather than numElementsInArray would have an impact